summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2016-04-17 16:16:31 -0300
committerHugo Osvaldo Barrera2016-04-17 16:16:31 -0300
commit4691d0ffeac1846360a5634060da93fbeaf0529f (patch)
tree6a7de90a6fc34d95c115a01774cb33b89a6d3285 /PKGBUILD
parentc8f48e485a7b175ee3c8da2c7a5802eb2e0af541 (diff)
downloadaur-4691d0ffeac1846360a5634060da93fbeaf0529f.tar.gz
Implement check()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b0903a4a52d..8a63f19e94e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=todoman-git
_pkgname=todoman
pkgver=latest
-pkgrel=5
+pkgrel=6
pkgdesc="A simple CalDav-based todo manager."
arch=("any")
url="https://github.com/pimutils/todoman"
@@ -12,6 +12,7 @@ depends=(python-icalendar python-urwid python-xdg python-ansi
python-parsedatetime python-atomicwrites python-click
python-setuptools-scm)
optdepends=('python-click-repl-git: the repl command.')
+checkdepends=('python-pytest' 'python-hypothesis')
conflicts=("todoman")
provides=("todoman")
source=(git+https://github.com/pimutils/todoman.git)
@@ -27,6 +28,13 @@ build() {
python setup.py build
}
+check() {
+ cd "$srcdir/$_pkgname"
+
+ export PYTHONPATH=$(pwd)
+ py.test
+}
+
package() {
cd "$srcdir/$_pkgname"
python setup.py install --root="$pkgdir"