summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122021-06-16 15:16:46 +0200
committerwillemw122021-06-16 15:18:04 +0200
commit6756cba1c0b88c1f5504d6f7c17a8b0da9f4e3ff (patch)
tree56b22c28a9ee359ec8c957ee0cb7546a90f1afb7 /PKGBUILD
parentf9c55d4453cba7b339918cf3ed0da306317e0a44 (diff)
downloadaur-6756cba1c0b88c1f5504d6f7c17a8b0da9f4e3ff.tar.gz
2.12.0.post1
Use Makefile Minor edits
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 27 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2046a06ac198..50e332e56692 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,36 @@
-# lifehacker.com's todo.sh script for maintaining a todo.txt file
-# Maintainer: Tatsunori Aoki <ginjiro.135 at gmail dot com>
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Tatsunori Aoki <ginjiro.135 at gmail dot com>
# Contributor: David Rosenstrauch <darose@darose.net>
+#_srcname=todo.txt_cli
+#_srcname=todo.txt-cli
pkgname=todotxt
-_pkgname=todo.txt_cli
-pkgver=2.12.0
+#pkgver=2.12.0
+pkgver=2.12.0.post1
pkgrel=1
-pkgdesc="lifehacker.com's todo.sh script for maintaining a todo.txt file"
+pkgdesc="Simple and extensible shell script for managing your todo.txt file"
+arch=('any')
url="https://github.com/todotxt/todo.txt-cli"
-depends=('bash')
+license=('GPL3')
install=$pkgname.install
-source=(https://github.com/todotxt/todo.txt-cli/releases/download/v${pkgver}/$_pkgname-${pkgver}.tar.gz)
-arch=('any')
-license=('GPL')
-md5sums=('6e5865091c4105491a82e9d5514ce5a9')
+#source=(https://github.com/todotxt/todo.txt-cli/releases/download/v$pkgver/$_srcname-$pkgver.tar.gz)
+#source=($_srcname-$pkgver::https://github.com/todotxt/$_srcname/archive/refs/tags/v$pkgver.tar.gz)
+source=($pkgname-$pkgver::git+$url.git#commit=77c1f34609070135143f29395edc647a2d308311)
+sha256sums=('SKIP')
-package() {
- cd $srcdir/$_pkgname-$pkgver
- install -D -m644 todo.cfg $pkgdir/usr/share/$pkgname/todo.cfg
- install -D -m755 todo.sh $pkgdir/usr/bin/todo.sh
+build() {
+ #cd $_srcname-$pkgver
+ cd $pkgname-$pkgver
+ make
+}
- install -d $pkgdir/usr/share/bash-completion/completions/
- install -D -m644 todo_completion $pkgdir/usr/share/bash-completion/completions/todo.sh
+check() {
+ cd $pkgname-$pkgver
+ make test
}
+
+package() {
+ cd $pkgname-$pkgver
+ make install CONFIG_DIR=$pkgdir/etc INSTALL_DIR=$pkgdir/usr/bin BASH_COMPLETION=$pkgdir/usr/share/bash-completion/completions
+}
+