summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSteffen Weber2015-06-10 15:09:47 +0200
committerSteffen Weber2015-06-10 15:09:47 +0200
commitc96e369730404009680421845e4f7556419bff96 (patch)
tree656ee287e3fd8d2820dd191bcc4463d92518e3a3 /PKGBUILD
downloadaur-c96e369730404009680421845e4f7556419bff96.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a4559c5af782
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Steffen Weber <-boenki-gmx-de->
+# Contributor: Nick Smallbone <nick.smallbone@gmail.com>
+
+pkgname=tofrodos
+pkgver=1.7.13
+pkgrel=2
+arch=('i686' 'x86_64')
+pkgdesc="Convert ASCII files between the MS-DOS/Windows format and the UNIX format"
+url="http://www.thefreecountry.com/tofrodos/index.shtml"
+license=('GPL2')
+conflicts=('dos2unix' 'hd2u')
+depends=('glibc')
+source=(http://$pkgname.sourceforge.net/download/$pkgname-$pkgver.tar.gz)
+md5sums=('c4c5e6668a13a01bfb5ce562753a808f')
+
+build() {
+ export CFLAGS+=" -c -Wall"
+ cd "$pkgname/src"
+ make -e
+}
+
+package() {
+ cd "$pkgname/src"
+ install -d "$pkgdir"/usr/{bin,share/man/man1}
+ make BINDIR="$pkgdir/usr/bin" MANDIR="$pkgdir/usr/share/man/man1" install
+ ln -s todos "$pkgdir/usr/bin/unix2dos"
+ ln -s fromdos "$pkgdir/usr/bin/dos2unix"
+}