summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSandaruKasa2024-05-05 16:10:58 +0300
committerSandaruKasa2024-05-05 16:10:58 +0300
commit6d0bfe1f7d21ec30d9b8265c36d84670134d7f19 (patch)
tree1900b01e7614f2e6b1c16f704a9c0e5186ad0aab /PKGBUILD
parentf9f0bbf6bee6f93e3d85db7556db45a551d71bfa (diff)
downloadaur-6d0bfe1f7d21ec30d9b8265c36d84670134d7f19.tar.gz
Fix upstream issues with Sland & Headache
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40f26bdada78..2498951597c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,25 @@
pkgname=tokei-git
epoch=1
-pkgver=13.0.0_alpha.0.r986.e2625c0
+pkgver=13.0.0_alpha.1.r1010.ba11288
pkgrel=1
pkgdesc='A blazingly fast CLOC(Count Lines Of Code) program'
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/XAMPPRocky/${pkgname%-git}"
-license=('MIT' 'Apache')
+license=("Apache-2.0 OR MIT")
makedepends=(git rust cargo coreutils sed gcc)
options=(!lto)
depends=(gcc-libs glibc)
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
_git_folder="${pkgname%-git}"
-source=("${_git_folder}::git+$url.git")
-sha256sums=(SKIP)
+source=("${_git_folder}::git+$url.git"
+"slang.patch::https://github.com/XAMPPRocky/tokei/commit/0c8a61393e105e2cd80eab61a166fcc89cb4853a.patch"
+"headache.patch::https://patch-diff.githubusercontent.com/raw/XAMPPRocky/tokei/pull/971.patch"
+)
+sha256sums=('SKIP'
+ '9e3e103d7c46f7a83ec351da5edb6fff8c7931f0b3fdc8836fc7b41c3d88e633'
+ '9140341fa58c1a4208ed2aacbe0bee43784391ca3ea099f2f3ddcd925bea1a3d')
pkgver() {
cd "${_git_folder}"
@@ -27,6 +32,8 @@ pkgver() {
prepare() {
cd "${_git_folder}"
+ patch -N -p 1 -i ../slang.patch
+ patch -R -p 1 -i ../headache.patch
cargo fetch --locked --target "${CARCH}-unknown-linux-gnu"
}