summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordadosch2018-10-28 21:04:44 +0100
committerdadosch2018-10-28 21:04:44 +0100
commit881ebe4e42247549c217021fe9ed00d0cd0b3eca (patch)
tree02054b8cbfc3a685fb259c1e1313af9ab90074bb /PKGBUILD
downloadaur-881ebe4e42247549c217021fe9ed00d0cd0b3eca.tar.gz
initial AUR entry for toot
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e2fc9bde7c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=toot
+_name=toot
+pkgver=0.19.0
+pkgrel=1
+pkgdesc="a Mastodon CLI client"
+license=('GPL3')
+arch=('any')
+url="https://github.com/ihabunek/toot"
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz)
+sha256sums=('857adc08ed2531c934a69d64efc78cd96bca80dd0a2b41e9033bdd61a50d6ffd')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}