summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMax Harmathy2021-08-25 13:18:48 +0200
committerMax Harmathy2021-08-25 13:19:10 +0200
commit0d5d66c867e9976f48e47c092c42b82ed5b189b5 (patch)
tree0b52e3e11589e5046cd18ca493fb16c1743a8a87 /PKGBUILD
parent220a25a115828f182bc80e4b82fa19f441ffa78b (diff)
downloadaur-0d5d66c867e9976f48e47c092c42b82ed5b189b5.tar.gz
Add a patch to fix build with libsoup 2.74.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b2bf1b3c50e..68cb7d130afa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=tootle
pkgver=1.0
_pkgver=${pkgver//_/-}
-pkgrel=3
+pkgrel=4
pkgdesc="GTK3 client for Mastodon"
arch=('x86_64' 'aarch64')
url="https://github.com/bleakgrey/tootle"
@@ -23,7 +23,6 @@ optdepends=(
makedepends=(
'cmake'
'desktop-file-utils'
- 'git'
'gnome-common'
'gobject-introspection'
'hicolor-icon-theme'
@@ -34,11 +33,18 @@ makedepends=(
'yelp-tools'
)
options=('!libtool')
-source=("https://github.com/bleakgrey/$pkgname/archive/${_pkgver}.tar.gz")
-sha256sums=('e0a0a062b1b72010242f7bb4db97cd71190f23067188b5c07372264d768a0496')
+source=(
+ "https://github.com/bleakgrey/$pkgname/archive/${_pkgver}.tar.gz"
+ "Use-reason_phrase-instead-of-get_phrase.patch"
+)
+sha256sums=('e0a0a062b1b72010242f7bb4db97cd71190f23067188b5c07372264d768a0496'
+ '06314649f967661defaf5d847a9ecdf4b942299a08613c4f3087afa6ecf5d7fc')
build() {
cd "${srcdir}/${pkgname}-${_pkgver}"
+
+ patch -p1 < "$startdir/Use-reason_phrase-instead-of-get_phrase.patch"
+
arch-meson build
ninja -C build
}