summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMax Harmathy2020-12-08 11:50:18 +0100
committerMax Harmathy2020-12-08 11:59:44 +0100
commitc5c4270919cf113e39a3a12b0a4bb4c357454881 (patch)
tree7c7caa305131704b2571f940bfd65fe04e134654 /PKGBUILD
parentc0b52cc5058f1f8b77c2ce93735dc9cb99217f34 (diff)
downloadaur-c5c4270919cf113e39a3a12b0a4bb4c357454881.tar.gz
Upstream release 1.0-alpha2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dea485d8a430..214ea52f9a47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Max Harmathy <max.harmathy@web.de>
# Contributor: Wesley Moore <wes@wezm.net>
pkgname=tootle
-pkgver=0.2.0
-pkgrel=4
+pkgver=1.0_alpha2
+_pkgver=${pkgver//_/-}
+pkgrel=1
pkgdesc="GTK3 client for Mastodon"
arch=('x86_64')
url="https://github.com/bleakgrey/tootle"
@@ -11,24 +12,17 @@ depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'libsoup' 'granite' 'json-glib')
optdepends=('noto-fonts-emoji: color emoji')
makedepends=('git' 'desktop-file-utils' 'hicolor-icon-theme' 'intltool' 'yelp-tools' 'gnome-common' 'gobject-introspection' 'meson' 'ninja' 'vala')
options=('!libtool')
-source=("https://github.com/bleakgrey/$pkgname/archive/${pkgver//_/-}.tar.gz"
- "fix-build-on-vala-46.patch")
-sha256sums=('e83c4a0539bf7b4b9d2b81d036ee0e8a69564b11c70f77ded5091955a89d2737'
- '5158d1e2019eaf6f4fa043b8483f8dfa049335d572a2563a0d4f71f799cae2b0')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < ../fix-build-on-vala-46.patch
-}
+source=("https://github.com/bleakgrey/$pkgname/archive/${_pkgver}.tar.gz")
+sha256sums=('7094adf37a177782a0cfc9c4d951a96e646bd496a74ac7e121b8c67e710d9199')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- arch-meson -Db_pie=false build
+ cd "${srcdir}/${pkgname}-${_pkgver}"
+ arch-meson build
ninja -C build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- DESTDIR="${pkgdir}/" ninja -C build install
+ cd "${srcdir}/${pkgname}-${_pkgver}"
+ DESTDIR="$pkgdir" ninja -C build install
ln -s "/usr/bin/com.github.bleakgrey.tootle" "${pkgdir}/usr/bin/tootle"
}