summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Moch2018-11-10 15:22:10 -0500
committerDaniel Moch2018-11-10 15:22:10 -0500
commit561ca1ca2a3ba60b07620de2b328ac28853d42bb (patch)
tree92cdd58abd4f52189ca7503de696932f9ff2a861 /PKGBUILD
parent57199a9f9a365128dab70f3f0eb2bea347b8e7b7 (diff)
downloadaur-561ca1ca2a3ba60b07620de2b328ac28853d42bb.tar.gz
upgpkg: tootstream-git 0.3.6.r7.gf2f8b8d-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 19 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 73c294a6e4d1..ce81907856a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,31 @@
# Contributor: Drew DeVault <sir@cmpwn.com>
_pkgname=tootstream
pkgname=tootstream-git
-pkgver=0.3.4.r3.gfef1e72
-pkgrel=5
+pkgver=0.3.6.r7.gf2f8b8d
+pkgrel=1
pkgdesc='Text interface for the Mastodon social network'
-provides=('tootstream')
-conflicts=('tootstream')
+provides=(tootstream)
+conflicts=(tootstream)
arch=('any')
url='https://github.com/magicalraccoon/tootstream'
-license=('MIT')
-depends=(
- 'python-mastodon'
- 'python-humanize'
- 'python-click'
- 'python-colored'
- 'python-emoji'
- 'python-http-ece'
- )
-makedepends=('python-distribute' 'git')
+license=(MIT)
+depends=(python-mastodon
+ python-humanize
+ python-click
+ python-colored
+ python-emoji
+ python-http-ece)
+makedepends=(python-setuptools git)
source=("git://github.com/magicalraccoon/${_pkgname}.git")
sha512sums=('SKIP')
+prepare()
+{
+ cd "${srcdir}/${_pkgname}"
+ sed -ie 's/\sasync=True/run_async=True/' src/tootstream/toot.py
+ sed -ie 's/Mastodon.py==1\.3\.1/Mastodon.py/g' requirements.txt
+}
+
pkgver()
{
cd "${srcdir}/${_pkgname}"
@@ -31,7 +36,6 @@ pkgver()
build()
{
cd "${srcdir}/${_pkgname}"
- sed -i -e 's/\sasync=True/run_async=True/' src/tootstream/toot.py
python ./setup.py build
}