summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Moch2018-07-23 21:06:47 -0400
committerDaniel Moch2018-07-23 21:14:11 -0400
commitf4a1cc5a394c64f46d1bb1db5a7ee29eb958c0a3 (patch)
treeedf13217b8f3ca36a86fc921eab6a3eeca7aefdf /PKGBUILD
downloadaur-f4a1cc5a394c64f46d1bb1db5a7ee29eb958c0a3.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8144f12a0b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Daniel Moch <daniel@danielmoch.com>
+# Contributor: Drew DeVault <sir@cmpwn.com>
+_pkgname=tootstream
+pkgname=tootstream-git
+pkgver=0.3.4.r3.gfef1e72
+pkgrel=1
+pkgdesc='Text interface for the Mastodon social network'
+provides=('tootstream')
+conflicts=('tootstream')
+arch=('any')
+url='https://github.com/magicalraccoon/tootstream'
+license=('MIT')
+depends=(
+ 'python-mastodon'
+ 'python-humanize'
+ 'python-click'
+ 'python-colored'
+ 'python-emoji'
+)
+makedepends=('python-distribute' 'git')
+source=("git://github.com/magicalraccoon/${_pkgname}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python ./setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}