summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoey Darwish Dror2018-06-10 12:51:01 +0300
committerRoey Darwish Dror2018-06-10 12:51:55 +0300
commitb7c389c0440196c22ad9049eea5d13647d735cd9 (patch)
treef740ac9a2b2bdcb76c6e39fb3c0d840a2b70fc62 /PKGBUILD
downloadaur-b7c389c0440196c22ad9049eea5d13647d735cd9.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b24e654fc8be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Roey Darwish Dror <roey.ghost@gmail.com>
+
+pkgname=topgrade
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='Invoke the upgrade proceadure of multiple package managers'
+arch=('x86_64' 'armv7')
+url='https://github.com/r-darwish/topgrade'
+license=('GPL3')
+makedepends=('rust')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('2bdef1a1bd3ae7e85299f74f504a3fc87df223a4ccebd9bc175f6eb473f3bac1')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 target/release/$pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}