summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgrufo2022-12-25 22:32:53 +0100
committergrufo2022-12-25 22:32:53 +0100
commit787bfa18e216f9039668db6c2653eb2b98d302db (patch)
tree00d9281b8dfbf10e4aed38657bfcd927150be569 /PKGBUILD
parentdc539abaf199f040e9021ee895928bfada2b744c (diff)
downloadaur-787bfa18e216f9039668db6c2653eb2b98d302db.tar.gz
New release (12.0.1-1) and end of PKGBUILD localization machinery
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD80
1 files changed, 14 insertions, 66 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df2f9cb6a6bc..f1eea52117a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,9 +17,9 @@
pkgname='tor-browser'
-pkgver='12.0'
+pkgver='12.0.1'
pkgrel=1
-pkgdesc='Tor Browser Bundle: anonymous browsing using Firefox and Tor (international PKGBUILD)'
+pkgdesc='Tor Browser Bundle: anonymous browsing using Firefox and Tor'
url='https://www.torproject.org/projects/torbrowser.html'
arch=('i686' 'x86_64')
license=('GPL')
@@ -33,49 +33,20 @@ optdepends=('zenity: simple dialog boxes'
'libpulse: PulseAudio audio driver'
'libnotify: Gnome dialog boxes')
install="${pkgname}.install"
+validpgpkeys=('EF6E286DDA85EA2A4BA7DE684E2C6E8793298290')
_tag_i686='linux32'
_tag_x86_64='linux64'
_urlbase="https://dist.torproject.org/torbrowser/${pkgver}"
_archstr=$([[ "${CARCH}" == 'x86_64' ]] && echo -n "${_tag_x86_64}" || echo -n "${_tag_i686}")
-
-_localetor() {
-
- #
- # Checking if a `tor-browser` package exists for current locale; a different language can be
- # chosen by giving a `TORBROWSER_PKGLANG` environment variable to `makepkg`, for instance:
- #
- # TORBROWSER_PKGLANG='en-US' makepkg
- #
-
- if [[ -n "${TORBROWSER_PKGLANG}" ]]; then
- echo -n "${TORBROWSER_PKGLANG}"
- return 0
- fi
-
- local _fulllocale="$(locale | grep LANG | cut -d= -f2 | cut -d. -f1 | sed s/_/\-/)"
- local _shortlocale="$(locale | grep LANG | cut -d= -f2 | cut -d_ -f1)"
-
- if curl --output /dev/null --silent --head --fail "${_urlbase}/${pkgname}-${_archstr}-${pkgver}_${_fulllocale}.tar.xz"; then
- echo -n "${_fulllocale}"
- elif curl --output /dev/null --silent --head --fail "${_urlbase}/${pkgname}-${_archstr}-${pkgver}_${_shortlocale}.tar.xz"; then
- echo -n "${_shortlocale}"
- else
- echo -n 'ALL'
- fi
-
-}
-
-_language="$(_localetor)"
-
-validpgpkeys=('EF6E286DDA85EA2A4BA7DE684E2C6E8793298290')
+_pkgsuffx='ALL'
# Syntax: _dist_checksum 'linux32'/'linux64'
_dist_checksum() {
(curl --silent --fail "${_urlbase}/sha256sums-signed-build.txt" || \
curl --silent --fail "${_urlbase}/sha256sums-unsigned-build.txt") | \
- grep "${1}-${pkgver}_${_language}.tar.xz\$" | cut -d ' ' -f1
+ grep "${1}-${pkgver}_${_pkgsuffx}.tar.xz\$" | cut -d ' ' -f1
}
@@ -84,8 +55,8 @@ _sed_escape() {
echo "${1}" | sed 's/[]\/&.*$^[]/\\&/g'
}
-source_i686=("${_urlbase}/${pkgname}-${_tag_i686}-${pkgver}_${_language}.tar.xz"{,.asc})
-source_x86_64=("${_urlbase}/${pkgname}-${_tag_x86_64}-${pkgver}_${_language}.tar.xz"{,.asc})
+source_i686=("${_urlbase}/${pkgname}-${_tag_i686}-${pkgver}_${_pkgsuffx}.tar.xz"{,.asc})
+source_x86_64=("${_urlbase}/${pkgname}-${_tag_x86_64}-${pkgver}_${_pkgsuffx}.tar.xz"{,.asc})
source=("${pkgname}.desktop.in"
"${pkgname}.in"
"${pkgname}.png"
@@ -95,8 +66,8 @@ source=("${pkgname}.desktop.in"
# No need for `makepkg -g`: the following sha256sums¸don't need to be updated #
# with each release, everything is done automatically! Leave them like this! #
###############################################################################
-sha256sums=('9af2a432bd6fbcdba8f849350e6f8abd68287d40689e59650bb1ef5d1d766af7'
- '8e171f7ef77058648a88d6b2683db458b217e47597a7ec9232a9505766916cca'
+sha256sums=('5dd2b61bd4edf4d1499a81127f97a1de7ec272a885df97331b61969a5a07f05f'
+ '1143d23e347605b498b3793992e84e95563efd94aa4da17837b37104a6d4a090'
'f25ccf68b47f5eb14c6fec0664c74f30ea9c6c58d42fc6abac3b64670aaa3152'
'7b28b5dbe8ad573bb46e61b4d542b33e01ca240825ca640b4893fee6203b021f')
sha256sums_i686=("$(_dist_checksum "${_tag_i686}")"
@@ -104,31 +75,8 @@ sha256sums_i686=("$(_dist_checksum "${_tag_i686}")"
sha256sums_x86_64=("$(_dist_checksum "${_tag_x86_64}")"
'SKIP')
-noextract=("${pkgname}-${_tag_i686}-${pkgver}_${_language}.tar.xz"
- "${pkgname}-${_tag_x86_64}-${pkgver}_${_language}.tar.xz")
-
-prepare() {
-
- # use colors only if we have them
- if [[ $(which tput > /dev/null 2>&1 && tput -T "${TERM}" colors || echo -n '0') -ge 8 ]] ; then
- local _COL_YELLOW_='\e[0;33m'
- local _COL_LIGHTGREY_='\e[0;37m'
- local _COL_BRED_='\e[1;31m'
- local _COL_BBLUE_='\e[1;34m'
- local _COL_BWHITE_='\e[1;37m'
- local _COL_DEFAULT_='\e[0m'
- fi
-
- msg "Packaging ${pkgname} (language: ${_language})..."
-
- if [[ -z "${TORBROWSER_PKGLANG}" ]]; then
- echo -e "\n ${_COL_BBLUE_}->${_COL_DEFAULT_} ${_COL_BRED_}NOTE:${_COL_DEFAULT_} If you want to package ${_COL_BWHITE_}${pkgname}${_COL_DEFAULT_} in a different language, please"
- echo -e " set a \`${_COL_YELLOW_}TORBROWSER_PKGLANG${_COL_DEFAULT_}\` environment variable before running makepkg.\n"
- echo ' For instance:'
- echo -e "\n ${_COL_LIGHTGREY_}TORBROWSER_PKGLANG='en-US' makepkg${_COL_DEFAULT_}\n"
- fi
-
-}
+noextract=("${pkgname}-${_tag_i686}-${pkgver}_${_pkgsuffx}.tar.xz"
+ "${pkgname}-${_tag_x86_64}-${pkgver}_${_pkgsuffx}.tar.xz")
package() {
@@ -138,7 +86,7 @@ package() {
s/@PACKAGE_NAME@/$(_sed_escape "${pkgname}")/g
s/@PACKAGE_VERSION@/$(_sed_escape "${pkgver}")/g
s/@PACKAGE_RELEASE@/$(_sed_escape "${pkgrel}")/g
- s/@PACKAGE_LANGUAGE@/$(_sed_escape "${_language}")/g
+ s/@PACKAGE_SUFFIX@/$(_sed_escape "${_pkgsuffx}")/g
s/@PACKAGE_ARCH@/$(_sed_escape "${_archstr}")/g
"
@@ -157,8 +105,8 @@ package() {
sed "${_sed_subst}" "${pkgname}.desktop.in" > \
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm444 "${pkgname}-${_archstr}-${pkgver}_${_language}.tar.xz" \
- "${pkgdir}/opt/${pkgname}/${pkgname}-${_archstr}-${pkgver}_${_language}.tar.xz"
+ install -Dm444 "${pkgname}-${_archstr}-${pkgver}_${_pkgsuffx}.tar.xz" \
+ "${pkgdir}/opt/${pkgname}/${pkgname}-${_archstr}-${pkgver}_${_pkgsuffx}.tar.xz"
}