summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorskydrome2019-02-24 22:58:56 -0500
committerskydrome2019-02-24 22:58:56 -0500
commit6afe3d337e5f2b8a1088d16199b53df366872697 (patch)
treeffbea1750466faae9c4f9348a824fe14afb27b10 /PKGBUILD
parent233945556432bc3d92846689d1d22c27fee2fe8f (diff)
downloadaur-6afe3d337e5f2b8a1088d16199b53df366872697.tar.gz
get rust submodule in prepare()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 869e3497cc90..ef2782628092 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,16 +53,16 @@ pkgver () {
prepare() {
cd tor
+
+ [[ $_with_rust ]] &&
+ git submodule update --init --recursive
+
./autogen.sh
}
build() {
cd tor
-
- [[ $_with_rust ]] && {
- git submodule update --init --recursive
- export TOR_RUST_DEPENDENCIES="$srcdir/tor/src/ext/rust/crates"
- }
+ export TOR_RUST_DEPENDENCIES="$srcdir/tor/src/ext/rust/crates"
./configure $_options \
--prefix=/usr --sysconfdir=/etc --localstatedir=/var \