summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Kuther2015-07-30 15:06:15 +0200
committerThomas Kuther2015-07-30 15:06:15 +0200
commit575ac9821f78c20382937cebb939f72075c767f9 (patch)
tree0b65a04de4044143bf12e4f954c03095ea8b3ecd /PKGBUILD
parent0a3a1ab88064ce5facf32b1d88d3b4ba39325675 (diff)
downloadaur-575ac9821f78c20382937cebb939f72075c767f9.tar.gz
fix versioning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72c4c3f70003..a97f6cd06b5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tom Kuther <gimpel@sonnenkinder.org>
pkgname=tora-git
_gitname=tora
-pkgver=3.0.0.svn.5182
+pkgver=3.0.0.git.692d6d7
pkgrel=1
pkgdesc="Toolkit for databases with support for Oracle, MySQL and PostgreSQL"
arch=('i686' 'x86_64')
@@ -24,13 +24,14 @@ pkgver() {
_major=`grep 'SET (VERSION_MAJOR' CMakeLists.txt|awk -F'("|")' '{print $2}'`
_minor=`grep 'SET (VERSION_MINOR' CMakeLists.txt|awk -F'("|")' '{print $2}'`
_patch=`grep 'SET (VERSION_PATCH' CMakeLists.txt|awk -F'("|")' '{print $2}'`
- _gitrev=`git rev-parse --short`
- echo "${_major}.${_minor}.${_patch}.svn.${_gitrev}"
+ _gitrev=`git rev-parse --short HEAD`
+ echo "${_major}.${_minor}.${_patch}.git.${_gitrev}"
}
build() {
cd $_gitname
+ test -d build && rm -rf build
mkdir build
cd build
cmake .. \