summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 13:53:28 +0100
committerBartłomiej Piotrowski2018-01-07 13:53:28 +0100
commit989015835159bf519f0265b20a7d6c92f5ea017a (patch)
tree7e77ebc9d39b9e1caa21212102cbae768735e91b /PKGBUILD
downloadaur-989015835159bf519f0265b20a7d6c92f5ea017a.tar.gz
Import from official repositories
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2ea4ebba08a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Shahar Weiss <sweiss4@gmx.net>
+
+pkgname=torcs
+pkgver=1.3.7
+pkgrel=1
+pkgdesc="A 3D racing cars simulator using OpenGL"
+url="http://torcs.sourceforge.net"
+license=("GPL")
+arch=('x86_64')
+depends=('freeglut' 'libpng' 'freealut' 'libxi' 'libxmu' 'libxrandr' 'libvorbis' 'glu')
+makedepends=('plib' 'mesa')
+options=('!makeflags')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-${pkgver/_/-}.tar.bz2
+ build-fix.patch)
+md5sums=('de314c3e421e8d7d4323d819c5010d23'
+ 'e011b533142879b1a399ce1cdeb1772c')
+
+prepare() {
+ cd "$srcdir"/$pkgname-${pkgver/_/-}
+ patch -p1 <"$srcdir"/build-fix.patch
+}
+
+build() {
+ cd "$srcdir"/$pkgname-${pkgver/_/-}
+ unset LDFLAGS
+ ./configure --prefix=/usr --x-includes=/usr/include --x-libraries=/usr/lib
+ make
+}
+
+package() {
+ depends=(${depends[@]} "torcs-data=$pkgver")
+ cd "$srcdir"/$pkgname-${pkgver/_/-}
+ make DESTDIR="$pkgdir" install
+ install -D -m644 Ticon.png "$pkgdir"/usr/share/pixmaps/torcs.png
+ install -D -m644 torcs.desktop "$pkgdir"/usr/share/applications/torcs.desktop
+ find "$pkgdir" -type d -exec chmod 755 {} \;
+}