summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorthatgeek2017-06-12 10:59:09 -0400
committerthatgeek2017-06-12 10:59:09 -0400
commitfd04e1ab368aa9dec1c1bf7643dfc8514ad5a3df (patch)
tree065b1f9a69ae206559accb846766ba42589da3d9 /PKGBUILD
parentddddf7d38d58e5342ed853e1575c067004f85260 (diff)
downloadaur-fd04e1ab368aa9dec1c1bf7643dfc8514ad5a3df.tar.gz
updated package to version 0.3.69
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce4f876aca55..f9bde51e0744 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
+# Maintainer: coco
+# Co-Maintainer: thatgeek
pkgname=torguard
-pkgver=0.3.67
+pkgver=0.3.69
pkgrel=1
pkgdesc="TorGuard VPN Software
Stay private online with TorGuard's anonymous VPN software and connect to 37+ countries worldwide."
@@ -7,19 +9,21 @@ arch=('x86_64')
url="www.torguard.com"
depends=('iproute2')
license=(custom)
-source=(code_x64_${pkgver}.tar.gz::http://updates.torguard.biz/Software/Linux/torguard-v0.3.67-amd64.tar.gz)
-md5sums=('399d193a0de01326cb56bccd7fbe4d40')
+source=(code_x64_${pkgver}.tar.gz::http://updates.torguard.biz/Software/Linux/torguard-v0.3.69-amd64.tar.gz)
+md5sums=('179cb7c1716740a2cedb66e0c0f1c02f')
package() {
mkdir -p "$pkgdir/opt/${pkgname}"
- cp -r "${srcdir}/${pkgname}-v0.3.67-amd64/"* "${pkgdir}/opt/${pkgname}" -R
- find "$pkgdir" -type f -exec chmod 644 {} \;
- find "$pkgdir" -name torguard -exec chmod 755 {} \;
- find "$pkgdir" -name torguard-wrapper -exec chmod 755 {} \;
- find "$pkgdir" -name ss-local -exec chmod 755 {} \;
- find "$pkgdir" -name openvpn -exec chmod 755 {} \;
+ cp -r "${srcdir}/${pkgname}-v0.3.69-amd64/"* "${pkgdir}/opt/${pkgname}" -R
+ find "$pkgdir"/opt/torguard/ -type f -exec chmod 644 {} \;
+ find "$pkgdir"/opt/torguard/ -name torguard -exec chmod 755 {} \;
+ find "$pkgdir"/opt/torguard/ -name torguard-wrapper -exec chmod 755 {} \;
+ find "$pkgdir"/opt/torguard/ -name ss-local -exec chmod 755 {} \;
+ find "$pkgdir"/opt/torguard/ -name openvpn -exec chmod 755 {} \;
+ find "$pkgdir"/opt/torguard/ -name openconnect -exec chmod 755 {} \;
+ find "$pkgdir"/opt/torguard/ -name vpnc-script -exec chmod 755 {} \;
install -d "$pkgdir"/usr/bin/
- ln -s /opt/torguard/bin/torguard "$pkgdir"/usr/bin/torguard
+ ln -s /opt/torguard/bin/torguard-wrapper "$pkgdir"/usr/bin/torguard
}