summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpushsla2020-05-14 19:13:56 +0300
committerpushsla2020-05-14 19:13:56 +0300
commit53b35cdf8c989e7f67b5733fa67f1432eafce5bf (patch)
tree5cd5af8b8fd48b9ae992feb1f2903d81a7a7ac82 /PKGBUILD
downloadaur-53b35cdf8c989e7f67b5733fa67f1432eafce5bf.tar.gz
0.9 pre-version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..555f7b046db8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Packager: push_sla <push2001sla@gmail.com>
+# Maintainer: pushsla <github.com/pushsla>
+
+pkgname=torodofi-git
+pkgver=0.9
+pkgrel=1
+pkgdesc="Simple To-Do task manager using pure MarkDown file to store your tasks. Active/Done, tags, deadlines support. Rofi GUI."
+arch=('x86_64')
+url="https://github.com/pushsla/torodofi"
+license=('MIT')
+groups=()
+depends=('rofi>=1.5.4' 'util-linux>=2.35.1')
+makedepends=('cmake>=3.10.0' 'gcc>=9.0.0' 'git>=2.25.0')
+source=("git+https://github.com/pushsla/torodofi.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/torodofi"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -S . -B build
+ cmake --build build
+}
+
+package() {
+ cd "$srcdir/torodofi"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir/torodofi/build"
+ make DESTDIR="$pkgdir/" install
+}