summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavić2016-01-07 01:25:40 +0100
committerJosip Ponjavić2016-01-07 01:25:40 +0100
commit3db465cc58fc3667d243c22ed3edad5ff849e755 (patch)
treec6e8e00922ff28039bc51efc659c088a0233a527 /PKGBUILD
downloadaur-3db465cc58fc3667d243c22ed3edad5ff849e755.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5cb6c898d8f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+# Contributor:
+
+pkgname=torrent-file-editor-qt5-git
+_pkgname=torrent-file-editor
+pkgver=v0.2.1.r28.g8462745
+pkgrel=1
+pkgdesc="Qt based GUI tool designed to create and edit .torrent files. Qt5 build"
+arch=('i686' 'x86_64')
+url='https://sourceforge.net/projects/torrent-file-editor/'
+license=('GPL3')
+depends=('desktop-file-utils' 'hicolor-icon-theme' 'qt5-base')
+makedepends=('cmake' 'git' 'qt5-tools')
+provides=("${_pkgname}" "${_pkgname}-qt5")
+conflicts=("${_pkgname}" "${_pkgname}-qt4")
+install="${_pkgname}.install"
+source=("git+https://github.com/drizt/torrent-file-editor.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_pkgname}"
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DQT5_BUILD=ON
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}