summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnshuman Bhaduri2016-03-05 01:44:02 +1300
committerAnshuman Bhaduri2016-03-05 01:46:24 +1300
commitaaaac6bd36b4ad57ad79b398d59684190b916ec1 (patch)
tree34d1bcb79ddf8d4c93ce727033c6f6ace345732d /PKGBUILD
parent125291d5381cb7ffd03039657146c7d0734f80d6 (diff)
downloadaur-aaaac6bd36b4ad57ad79b398d59684190b916ec1.tar.gz
Fixes pkgver for multiple tags for same revision.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e37d97d6bcec..a3f713242bca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname=thg
pkgname=tortoisehg-hg
-pkgver=3.4.1.17796
+pkgver=3.7.1.17982
pkgrel=1
pkgdesc="Mercurial GUI front end"
arch=('i686' 'x86_64')
@@ -28,7 +28,8 @@ md5sums=('SKIP'
pkgver() {
cd "${srcdir}/${_pkgname}"
# Version string will be similar to 2.7.2.14004
- echo $(hg parents --template {latesttag}).$(hg identify -n)
+ # Use the last tag when latesttag returns a list of tags
+ echo $(hg parents --template '{word(-1,latesttag,":")}').$(hg identify -n)
}
build() {