summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrien Gallouët2020-09-15 07:31:57 +0000
committerAdrien Gallouët2020-09-15 07:41:26 +0000
commit2808571947f76a87e2312d5e8f504893d894b46c (patch)
tree64c0bc34b0d417a96042441d808db8f41d23c839 /PKGBUILD
parent0b32549b799679317c67c9421270f6241a854f9b (diff)
downloadaur-2808571947f76a87e2312d5e8f504893d894b46c.tar.gz
Install LICENSE
Signed-off-by: Adrien Gallouët <adrien@gallouet.fr>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e97b9195ca10..a93c901e754b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Maintainer: Adrien Gallouët <adrien@gallouet.fr>
pkgname=totp
pkgver=0.1
-pkgrel=1
+pkgrel=2
pkgdesc="A tiny command line utility to generate OTP tokens"
arch=('x86_64')
url="https://github.com/angt/totp"
license=('BSD')
depends=()
makedepends=('git')
-source=("git+$url#tag=v${pkgver}")
+source=("git+$url#tag=v$pkgver")
md5sums=('SKIP')
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
package() {
cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir" prefix=/usr install
+ install -D -m0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}