summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYTG1232021-08-08 11:11:33 +0300
committerYTG1232021-08-08 11:11:33 +0300
commit2d173f8da8377decd89ee2a6aa324173ef2fa459 (patch)
tree695b896244e57e68aab2c225c832caef8f340a4b /PKGBUILD
downloadaur-2d173f8da8377decd89ee2a6aa324173ef2fa459.tar.gz
Initial package commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d40009f5f8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: YTG123 <ytg1234@pm.me>
+_pkgname=touchcursor-linux
+pkgname=touchcursor-linux-git
+pkgver=r96.1383893
+pkgrel=1
+pkgdesc="TouchCursor style keyboard remapping for Linux, Git version."
+arch=("any")
+url=https://github.com/donniebreve/touchcursor-linux
+license=('GPL2')
+depends=('glibc')
+source=("git+https://github.com/donniebreve/$_pkgname")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ make OUTPATH="./out" TARGET="touchcursor"
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm4755 out/touchcursor "$pkgdir/usr/bin/touchcursor"
+ install -Dm644 touchcursor.conf "$pkgdir/etc/touchcursor/touchcursor.conf"
+ install -Dm644 touchcursor.service "$pkgdir/usr/lib/systemd/user/touchcursor.service"
+}