summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-07-09 18:09:00 -0600
committerMark Wagie2021-07-09 18:09:00 -0600
commit19c277959f4d40774ed3ae681572597afb1b9f7b (patch)
tree03299e27217217eba952bd8332371ff9f9c90b7c /PKGBUILD
parenteeeffbc439e847c6430ca62d0245a971f30cd9a1 (diff)
downloadaur-19c277959f4d40774ed3ae681572597afb1b9f7b.tar.gz
revert previous commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4699fa0774f..53bac464adfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=touche
pkgver=1.0.6
-pkgrel=2
+pkgrel=3
pkgdesc="The desktop application to configure Touchégg "
arch=('x86_64')
url="https://github.com/JoseExposito/touche"
@@ -14,24 +14,22 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('116ecdd03070c55444f3d90263d7504a132c70ba4730a6d2fd6fd936c16b9fed')
build() {
- pushd "$pkgname-$pkgver"
- npm install --cache "$srcdir/npm-cache"
- popd
+ export npm_config_cache="$srcdir/npm_cache"
- if [ "$XDG_CURRENT_DESKTOP" = "Pantheon" ]; then
- arch-meson "$pkgname-$pkgver" build -Dtarget-de=elementary
- else
- arch-meson "$pkgname-$pkgver" build -Dtarget-de=gnome
- fi
+ cd "$pkgname-$pkgver"
+ npm install
+ arch-meson -Dtarget-de=gnome . build
meson compile -C build
}
check() {
+ cd "$pkgname-$pkgver"
meson test -C build --print-errorlogs
}
package() {
+ cd "$pkgname-$pkgver"
DESTDIR="$pkgdir" meson install -C build
ln -s "/usr/bin/com.github.joseexposito.$pkgname" "$pkgdir/usr/bin/$pkgname"