summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-03-27 11:14:45 -0600
committerMark Wagie2022-03-27 11:14:45 -0600
commit4e7bcd4a226ffe931bdc68d03dc8a1aeb807e783 (patch)
tree35c6ff3cbe942b2b95a24b650a5112ddacee074d /PKGBUILD
parent7ade23f500d84a18c62babf184085434ecb2c94d (diff)
downloadaur-4e7bcd4a226ffe931bdc68d03dc8a1aeb807e783.tar.gz
2.0.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e20808c6f2f6..20d789f0bd1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=touche
-pkgver=2.0.4
+pkgver=2.0.5
pkgrel=1
pkgdesc="The desktop application to configure Touchégg "
arch=('x86_64')
url="https://github.com/JoseExposito/touche"
license=('GPL3')
-depends=('gjs' 'gtk4' 'libadwaita' 'touchegg')
+depends=('gjs' 'libadwaita' 'touchegg')
makedepends=('gobject-introspection' 'meson' 'npm')
checkdepends=('appstream-glib')
provides=('libtouche.so')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('c7306fae8335b2209e2157106674c17802a7c83325fc5391d42f26a4b227160e')
+sha256sums=('4c3b8988cd2e324d67077a5914b094c11e9e850d11f8a0bcbf9e6a9a3d7b445a')
build() {
cd "$pkgname-$pkgver"
@@ -24,7 +24,9 @@ build() {
check() {
cd "$pkgname-$pkgver"
- meson test -C build --print-errorlogs
+
+ # Validate appstream file fails
+ meson test -C build 'Validate desktop file' 'Validate schema file' --print-errorlogs
}
package() {