summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-07-10 08:44:00 -0600
committerMark Wagie2021-07-10 08:44:00 -0600
commitc3cba99c7ec5a84398c10fd0f1b9b5e119a368f3 (patch)
tree3bffd38d480503717785ffce6292e03b088dc6bb /PKGBUILD
parent19c277959f4d40774ed3ae681572597afb1b9f7b (diff)
downloadaur-c3cba99c7ec5a84398c10fd0f1b9b5e119a368f3.tar.gz
check desktop type without breaking anything
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53bac464adfa..ea80932abce4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=touche
pkgver=1.0.6
-pkgrel=3
+pkgrel=4
pkgdesc="The desktop application to configure Touchégg "
arch=('x86_64')
url="https://github.com/JoseExposito/touche"
@@ -19,8 +19,11 @@ build() {
cd "$pkgname-$pkgver"
npm install
- arch-meson -Dtarget-de=gnome . build
- meson compile -C build
+ if [ "$XDG_CURRENT_DESKTOP" = "Pantheon" ]; then
+ arch-meson . build -Dtarget-de=elementary
+ else
+ arch-meson . build -Dtarget-de=gnome
+ fi
}
check() {