summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKenneth Flak2021-06-10 14:29:58 +0300
committerKenneth Flak2021-06-10 14:29:58 +0300
commite5d6a6148adf721194872ef06fe6da54f6bc6ab7 (patch)
tree46b0418aa675722c394bd0c7d1627ec06d34b836 /PKGBUILD
downloadaur-e5d6a6148adf721194872ef06fe6da54f6bc6ab7.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b22869a723d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Kenneth Flak <kennethflak@protonmail.com>
+
+pkgname=touchosc-bin
+pkgver=1.0.0.92
+pkgrel=1
+pkgdesc='Modular control surface'
+arch=('x86_64')
+url=http://hexler.net
+license=(custom:TouchOSC)
+source=("https://hexler.net/pub/touchosc/touchosc-$pkgver-linux-$arch.deb")
+sha256sums=('83469ec3aa776954d2eee2a52d58dab061593aab8605f99cf35b851fe0d4e6ef')
+
+package() {
+
+ cd "$srcdir"
+
+ ar vx "touchosc-$pkgver-linux-$arch.deb"
+ tar xzvf data.tar.gz
+
+ sed -i 's:opt/touchosc:usr/bin:g' usr/share/applications/touchosc.desktop
+
+ install -Dm755 $srcdir/opt/touchosc/TouchOSC $pkgdir/usr/bin/TouchOSC
+ install -Dm755 $srcdir/usr/share/applications/touchosc.desktop $pkgdir/usr/share/applications/touchosc.desktop
+
+}