summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBarbUk2023-07-12 10:41:26 +0200
committerBarbUk2023-07-12 10:41:26 +0200
commitdb3b406830eb8e03060014ce68238a74b97af55c (patch)
tree510e47a185cdebe95a74c547ae03cf7450daaf2e /PKGBUILD
parentb1b1e98227db66dc073514ec862bbb3165470800 (diff)
downloadaur-db3b406830eb8e03060014ce68238a74b97af55c.tar.gz
Fix for kernel 6.4+
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4cc4bf44f2c3..6d720ed44b14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,15 +11,19 @@ provides=("tp_smapi=${pkgver}")
options=(!strip)
source=("https://github.com/linux-thinkpad/tp_smapi/releases/download/tp-smapi%2F${pkgver}/tp_smapi-${pkgver}.tgz"
'dkms.conf'
- 'kbase.patch')
+ 'kbase.patch'
+ 'update_define_semaphore_usage_for_linux_6.4.patch')
sha256sums=('bcef9cd045d52a74d719b2a67ac4f5324994a856f123c0fbc55f1d769d367110'
'43aa280c078fc5ba0ee229b9c71238e215313315711f3d3caae7b9bd0ab24dbe'
- '4bcce516a9f3c486a934cfe6e3d3c92443833f4094ec008ce25264d1a5b66097')
+ '4bcce516a9f3c486a934cfe6e3d3c92443833f4094ec008ce25264d1a5b66097'
+ '24db4ff35d20c488582178ab2aa4d7d96c6125eaff95588be7e900a069df3ca9')
prepare() {
cd tp_smapi-${pkgver}
# patch Makefile for recent kernel module directory change
patch -p2 < "${srcdir}"/kbase.patch
+ # Patch for recent kernel
+ patch -p2 < "${srcdir}"/update_define_semaphore_usage_for_linux_6.4.patch
msg2 "Patching dkms.conf"
sed -ri 's/^(PACKAGE_VERSION=).*/\1'${pkgver}'/g' "${srcdir}"/dkms.conf
}