summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfrederik2016-04-21 18:38:12 +0200
committerfrederik2016-04-21 18:38:12 +0200
commit6a867f5df4c916ae90c30182cc397a74ab2d2cf0 (patch)
tree187974d712bbb785adfd30023069fb39de563d88 /PKGBUILD
parent8c4279f0906f950cde6bb34c19966c1dd1a7c0af (diff)
downloadaur-6a867f5df4c916ae90c30182cc397a74ab2d2cf0.tar.gz
update PKGBUILD to reflect recent changes
add dynamic setting of threshold via config file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 17 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4dfc7d2b28af..d19f28e5fd2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,29 @@
# Contributor: Lucky <archlinux@builds.lucky.li>
pkgname=tpacpi-bat-git
-_pkgname="${pkgname%-*}"
-pkgver=94.06ec1d5
+pkgver=106.f58e2ae
pkgrel=1
-pkgdesc="A Perl script with ACPI calls for recent ThinkPads (such as T420 and W520) whose battery thresholds are not supported by tp_smapi"
-url="https://github.com/teleshoes/tpacpi-bat"
-license=("GPLv3")
-arch=("any")
-depends=("perl" "acpi_call")
-makedepends=("git")
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
-source=("git://github.com/teleshoes/tpacpi-bat.git"
- "tlp.patch")
-md5sums=("SKIP"
- "9799f80a35939a0dd009d05c94418fbf")
+pkgdesc='A Perl script with ACPI calls for recent ThinkPads (such as T420 and W520) whose battery thresholds are not supported by tp_smapi'
+url='https://github.com/teleshoes/tpacpi-bat'
+license=('GPLv3')
+arch=('any')
+depends=('perl' 'acpi_call')
+makedepends=('git')
+conflicts=('tpacpi-bat')
+provides=('tpacpi-bat')
+backup=('etc/conf.d/tpacpi')
+source=('git://github.com/teleshoes/tpacpi-bat.git')
+sha256sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd ${pkgname/-git/}
echo $(git rev-list --count master).$(git rev-parse --short master)
}
-
-prepare() {
- cd "${_pkgname}"
-# patch -uNp1 -i "${srcdir}/tlp.patch"
-}
-
package() {
- cd "${_pkgname}"
+ cd ${pkgname/-git/}
- install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 "${_pkgname%-*}.service" "${pkgdir}/usr/lib/systemd/system/${_pkgname}.service"
+ install -Dm755 tpacpi-bat ${pkgdir}/usr/bin/tpacpi-bat
+ install -Dm644 examples/systemd_dynamic_threshold/tpacpi.service ${pkgdir}/usr/lib/systemd/system/tpacpi-bat.service
+ install -Dm644 examples/systemd_dynamic_threshold/tpacpi.conf.d ${pkgdir}/etc/conf.d/tpacpi
}