summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Witschel2021-12-17 18:46:55 +0100
committerJonas Witschel2021-12-17 18:46:55 +0100
commitc5bfbc78efc3805a9cd8e94b1570b9bf8ae45e48 (patch)
tree65add46d75b6b28e313b243e20898c873e9cec2f /PKGBUILD
parentd79fb56e196159b757b2caba123aa2073d7cf031 (diff)
downloadaur-tpm2-tools-git.tar.gz
tpm2-software: disable link time optimisation
The test suites of this package use -Wl,--wrap which does not work with LTO (https://gcc.gnu.org/bugzilla/show_bug.cgi?id=88643), so disable it for now.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47442495159c..efa14368b300 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonas Witschel <diabonas@archlinux.org>
# Contributor: Hexchain Tong <i at hexchain dot org>
pkgname=tpm2-tools-git
-pkgver=5.0.r15.713c2ab5
+pkgver=5.2.r64.7fc5a005
pkgrel=1
pkgdesc='Trusted Platform Module 2.0 tools based on tpm2-tss'
arch=('x86_64')
@@ -14,6 +14,7 @@ checkdepends=('cmocka' 'expect' 'iproute2' 'python-yaml' 'swtpm' 'tpm2-abrmd' 'x
optdepends=('tpm2-abrmd: user space resource manager')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
+options=('!lto')
source=("git+$url.git")
sha512sums=('SKIP')
@@ -41,5 +42,5 @@ check() {
package() {
cd "${pkgname%-git}"
make DESTDIR="$pkgdir" install
- install -Dm644 doc/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 docs/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}