summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Witschel2019-10-09 12:53:31 +0200
committerJonas Witschel2019-10-09 12:53:31 +0200
commit81d63442fce23dad7986a4083653fb9dd6eb50dd (patch)
treea93c73adced906859d0932379d099e22b471cce1 /PKGBUILD
parent40eb8bb550da6f3768a1d760d5ad362a06645a52 (diff)
downloadaur-81d63442fce23dad7986a4083653fb9dd6eb50dd.tar.gz
upgpkg: tpm2-totp-git 0.2.0rc0.r0.b15fac3-1
- mkinitcpio is not required for tests any more since upstream commit fbce78b934b951e0b9ee44281fdc63daf4d3b1a9. - Remove underscore preceeding "rc" in pkgver so that vercmp correctly sorts final versions after release candidates.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63d296014666..d5e70f7a494d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jonas Witschel <diabonas@archlinux.org>
pkgname=tpm2-totp-git
-pkgver=0.1.0.r73.a144c27
+pkgver=0.2.0rc0.r0.b15fac3
pkgrel=1
pkgdesc='Attest the trustworthiness of a device against a human using time-based one-time passwords'
arch=('x86_64')
@@ -8,7 +8,7 @@ url='https://github.com/tpm2-software/tpm2-totp'
license=('BSD')
depends=('qrencode' 'tpm2-tss')
makedepends=('git' 'autoconf-archive' 'doxygen' 'pandoc' 'plymouth')
-checkdepends=('ibm-sw-tpm2' 'iproute2' 'mkinitcpio' 'oath-toolkit' 'procps-ng' 'psmisc' 'tpm2-tools')
+checkdepends=('ibm-sw-tpm2' 'iproute2' 'oath-toolkit' 'procps-ng' 'psmisc' 'tpm2-tools')
optdepends=('initramfs: initramfs hooks to display the TOTP during boot'
'plymouth: display the TOTP during boot using plymouth messages')
provides=("${pkgname%-git}")
@@ -18,7 +18,7 @@ sha512sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+ git describe --long | sed 's/^v//;s/[-_]rc/rc/;s/\([^-]*-\)g/r\1/;s/-/./g'
}
prepare() {