summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Witschel2019-02-22 12:50:44 +0100
committerJonas Witschel2019-02-22 12:50:44 +0100
commitc1e40ee62008e9b130f2ef43b16b2bf1ca6970ba (patch)
tree39dde7535d8e225eee4ebf6e6bdff49d75b6ae9c /PKGBUILD
parentac1ee344fef12a3be7562bef6f123c1bc1188301 (diff)
downloadaur-c1e40ee62008e9b130f2ef43b16b2bf1ca6970ba.tar.gz
Update pkgver(), test suite must now be enabled in ./configure
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87daac5d20c1..e2085f36bb9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Jonas Witschel <diabonas at gmx dot de>
pkgname=tpm2-totp-git
-pkgver=r9.72cb0a4
+pkgver=0.1.0.rc0.r0.44fcb68
pkgrel=1
pkgdesc='Attest the trustworthiness of a device against a human using time-based one-time passwords'
arch=('x86_64')
url='https://github.com/tpm2-software/tpm2-totp'
license=('BSD')
depends=('qrencode' 'tpm2-tss')
-makedepends=('git' 'autoconf-archive' 'oath-toolkit' 'pandoc')
-checkdepends=('ibm-sw-tpm2' 'psmisc' 'tpm2-tools-git')
+makedepends=('git' 'autoconf-archive' 'pandoc')
+checkdepends=('ibm-sw-tpm2' 'oath-toolkit' 'psmisc' 'tpm2-tools-git')
optdepends=('mkinitcpio: hook to display the TOTP during boot')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -22,7 +22,7 @@ BUILDENV+=('!check') # see warning below before enabling tests
pkgver() {
cd "${pkgname%-git}"
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf '%s' "$(git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
prepare() {
@@ -32,7 +32,8 @@ prepare() {
build() {
cd "${pkgname%-git}"
- ./configure --prefix=/usr
+ (( CHECKFUNC )) && _opts=('--enable-integration')
+ ./configure --prefix=/usr "${_opts[@]}"
make
}