summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Witschel2020-07-23 16:30:15 +0200
committerJonas Witschel2020-07-23 16:30:15 +0200
commitef15a5b992363bedfa999a3bb558afc4e8b3339e (patch)
treed48da88e44e933bb5396caa36222c86e2c5e823f /PKGBUILD
parent37c706cc269f1bc8176c038f33ea086d4e9a445c (diff)
downloadaur-ef15a5b992363bedfa999a3bb558afc4e8b3339e.tar.gz
upgpkg: tpm2-totp-git 0.2.0.r6.b4f26a9-1: add libdepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f35e1ae7442..1948fde7cb7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Jonas Witschel <diabonas@archlinux.org>
pkgname=tpm2-totp-git
-pkgver=0.2.0rc0.r0.b15fac3
+pkgver=0.2.0.r6.b4f26a9
pkgrel=1
pkgdesc='Attest the trustworthiness of a device against a human using time-based one-time passwords'
arch=('x86_64')
url='https://github.com/tpm2-software/tpm2-totp'
license=('BSD')
-depends=('qrencode' 'tpm2-tss')
+depends=('qrencode' 'tpm2-tss' 'libtss2-esys.so' 'libtss2-mu.so' 'libtss2-tctildr.so')
makedepends=('git' 'autoconf-archive' 'doxygen' 'pandoc' 'plymouth')
checkdepends=('ibm-sw-tpm2' 'iproute2' 'oath-toolkit' 'procps-ng' 'tpm2-tools')
-optdepends=('initramfs: initramfs hooks to display the TOTP during boot'
+optdepends=('initramfs: dracut and mkinitcpio hooks to display the TOTP during boot'
'plymouth: display the TOTP during boot using plymouth messages')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -28,12 +28,11 @@ prepare() {
build() {
cd "${pkgname%-git}"
- (( CHECKFUNC )) && _opts=('--enable-integration')
./configure --prefix=/usr \
--libexecdir=/usr/lib \
--with-dracutmodulesdir=/usr/lib/dracut/modules.d \
--with-mkinitcpiodir=/usr/lib/initcpio \
- "${_opts[@]}"
+ $( ((CHECKFUNC)) && echo --enable-integration)
make
}