summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Brost2023-07-08 11:57:16 +0200
committerJulian Brost2023-07-08 12:01:28 +0200
commite0ed794bc82451efe4519d2b862d98182ba04db6 (patch)
tree086935530e301f90fbec1c7cb2d0adbc9a208753 /PKGBUILD
parent4fc69d9208f10d0c7a5a84719913ed53aa2b623a (diff)
downloadaur-e0ed794bc82451efe4519d2b862d98182ba04db6.tar.gz
remove example service file and install script
Installing the service file to /usr/lib/systemd/system made little sense anyways as it can't be used without editing it anyways. Also, by far not the only way to run Trac, I trust users to be able to pick their preferred method and implement it for their setup themselves. The install script became obsolete as it basically just said that the installed service file isn't usable in the default state.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fd3b9176d2a..4dfe9095c96e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,11 +16,8 @@ optdepends=('python2-psycopg2: PostgreSQL database support'
'python2-docutils: reStructuredText support'
'python2-babel: localization support'
'python2-pytz: complete list of time zones')
-install=trac.install
-source=(https://download.edgewall.org/trac/Trac-$pkgver.tar.gz
- tracd.service)
-sha256sums=('c93ceed9abee6e3c7789f469862e82a3b9bf3405be73aae3221b5c259e062d21'
- '3f050f1c9367b1b28e18a6ff0088f991676a9fbba3f5177859ce4db64f95ca42')
+source=(https://download.edgewall.org/trac/Trac-$pkgver.tar.gz)
+sha256sums=('c93ceed9abee6e3c7789f469862e82a3b9bf3405be73aae3221b5c259e062d21')
prepare() {
cd "$srcdir"/Trac-$pkgver
@@ -36,5 +33,4 @@ package() {
cd "$srcdir"/Trac-$pkgver
python2 setup.py install --prefix=/usr --root="$pkgdir"
install -D -m644 COPYING "$pkgdir"/usr/share/licenses/trac/COPYING
- install -Dm0644 "$srcdir"/tracd.service "$pkgdir"/usr/lib/systemd/system/tracd.service
}