summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2018-09-09 23:35:20 -0400
committerGI_Jack2018-09-09 23:35:20 -0400
commit3dda118c85fb422da695ea406fecb2d16960835b (patch)
tree1159be56d1916d1f61f99c73b8f222aac72476d4 /PKGBUILD
downloadaur-3dda118c85fb422da695ea406fecb2d16960835b.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1be88a9a568
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=trackerjacker
+pkgver=1.8.7
+pkgrel=1
+pkgdesc="Map and track WiFi networks and devices through raw 802.11 monitoring."
+arch=('any')
+url="https://github.com/calebmadrigal/trackerjacker"
+license=('MIT')
+depends=('python' 'python-setuptools' 'python-scapy' 'python-pyaml' 'python-ruamel-yaml')
+source=("https://files.pythonhosted.org/packages/d2/81/4dca960aeb78e070c1639ccbacfaa17182762f5c808c2eee0f1906c5fff4/trackerjacker-${pkgver}.tar.gz")
+sha256sums=('b6936241001d56abc126f5f0d00b71752b1405b889a71a343e0b57b25f23b858')
+
+package() {
+ cd "${pkgname}-$pkgver"
+ sed -i s/'ruamel.yaml==0.15.0'/'ruamel.yaml'/g requirements.txt
+ sed -i s/'scapy==2.4.0'/'scapy'/g requirements.txt
+ sed -i s/'pyaml>=17.12.1'/'pyaml'/g requirements.txt
+ python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+}