summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSumner Evans2018-07-07 22:32:39 -0600
committerSumner Evans2018-07-07 22:32:39 -0600
commit9910121628db978d89da84afd702811fd8599ca3 (patch)
tree0a51213b90f7260956d8123c291da4d1b80ee62e /PKGBUILD
downloadaur-9910121628db978d89da84afd702811fd8599ca3.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a37cbfa6939
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase=('tracktime')
+pkgname=('tracktime')
+_module='tracktime'
+pkgver='0.1.1'
+pkgrel=1
+pkgdesc="Time tracking library with command line interface."
+url="https://gitlab.com/sumner/tracktime"
+depends=('python')
+makedepends=('python-setuptools')
+license=('GPL3')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/t/tracktime/tracktime-${pkgver}.tar.gz")
+sha256sums=('fc7544ab2a8a3e59727e85350074210d1e736b34bd5c0474f84bfb93cc314855')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}