summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMathias Buhr2018-01-06 23:36:12 +0100
committerMathias Buhr2018-01-06 23:36:12 +0100
commit251024bd2c59b5d28743948b60251d1053d7a837 (patch)
treea60a89ce86428cf6a5d94c0280f57d40a8e9e014 /PKGBUILD
downloadaur-251024bd2c59b5d28743948b60251d1053d7a837.tar.gz
Initial package version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79d8eefce844
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mathias Buhr <napcode@aparatus.de>
+# Based on waveforum-bundle aur package from Paul B Davis <paul@dangersalad.com>
+# Based on tracktion-7 aur package from Felipe F. Tonello <eu@felipetonello.com>
+# Based on tracktion-6 aur package from boltbuckle <amygdala@cheerful.com>
+
+pkgname=tracktion-waveform
+pkgver=8.2.7
+pkgrel=1
+pkgdesc="Audio and MIDI Workstation (DAW)"
+arch=('x86_64')
+url="https://www.tracktion.com/"
+license=('custom')
+depends=('alsa-lib' 'libcurl-compat' 'freetype2' 'libglvnd')
+optdepends=(
+ 'jack: A low-latency audio server'
+ 'ladspa-plugins: A set of ladspa plugins'
+)
+conflicts=('waveform-bundle')
+source=(https://s3-us-west-2.amazonaws.com/tracktion-marketplace-public/archive/waveform/827/Waveform-installer-64bit-linux-8.2.7.deb)
+md5sums=('95bd25b2d5fe551949ddd2ade8eafe0b')
+
+package() {
+ executable=Waveform8
+ tar -x --lzma -f data.tar.lzma -C "${pkgdir}"
+ install -D -m 644 "$startdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ sed "s/@executable@/$executable/g" "$startdir/tracktion-waveform" > "$pkgdir/usr/bin/$pkgname"
+ chmod 755 "$pkgdir/usr/bin/$pkgname"
+ sed -i "s/Exec=.*/Exec=tracktion-waveform/" "$pkgdir/usr/share/applications/waveform8.desktop"
+ mv "$pkgdir/usr/share/doc/waveform8" "$pkgdir/usr/share/doc/$pkgname"
+}