summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMathias Buhr2018-01-06 23:37:56 +0100
committerMathias Buhr2018-01-06 23:37:56 +0100
commit92a5970b1f151464eddcb31e8637c902ff298a5e (patch)
treefa820c6352b5b07c43e15ef03056ff77c264bf7b /PKGBUILD
downloadaur-92a5970b1f151464eddcb31e8637c902ff298a5e.tar.gz
Initial package version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4aa0e9b5b8eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mathias Buhr <napcode@aparatus.de>
+# Based on waveforum-bundle aur package from Paul B Davis <paul@dangersalad.com>
+# Based on tracktion-7 aur package from Felipe F. Tonello <eu@felipetonello.com>
+# Based on tracktion-6 aur package from boltbuckle <amygdala@cheerful.com>
+
+pkgname=tracktion-waveform-beta
+pkgver=9.0.21
+pkgrel=1
+pkgdesc="Audio and MIDI Workstation (DAW)"
+arch=('x86_64')
+url="https://www.tracktion.com/"
+license=('custom')
+depends=('alsa-lib' 'libcurl-compat' 'freetype2' 'libglvnd')
+optdepends=(
+ 'jack: A low-latency audio server'
+ 'ladspa-plugins: A set of ladspa plugins'
+)
+conflicts=('waveform-bundle')
+source=(https://s3-us-west-2.amazonaws.com/tracktion-marketplace-public/archive/waveform/9021/Waveform-installer-64bit-linux-9.0.21.deb)
+md5sums=('ed4c5fcfc61ed3356532fb0d0626151c')
+
+package() {
+ executable=Waveform9
+ tar -x --lzma -f data.tar.lzma -C "${pkgdir}"
+ install -D -m 644 "$startdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ sed "s/@executable@/$executable/g" "$startdir/tracktion-waveform" > "$pkgdir/usr/bin/$pkgname"
+ chmod 755 "$pkgdir/usr/bin/$pkgname"
+ sed -i "s/Exec=.*/Exec=tracktion-waveform/" "$pkgdir/usr/share/applications/waveform9.desktop"
+ mv "$pkgdir/usr/share/doc/waveform9" "$pkgdir/usr/share/doc/$pkgname"
+}