summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAngelo Theodorou2023-03-09 00:42:17 +0100
committerAngelo Theodorou2023-03-09 00:42:17 +0100
commita6bd906c2c7aee86bd5d0022c0c7cf2fdf7e4228 (patch)
treeb4afed0df54a10ca5ceaa011129d9ee6f6e63f24 /PKGBUILD
parent1670824a6159d2f06ee85b7e7fb976bdd6c41a64 (diff)
downloadaur-a6bd906c2c7aee86bd5d0022c0c7cf2fdf7e4228.tar.gz
Update to v0.9.1
- Compile the profiler with LEGACY=1 to link against GLFW and use X11 - Remove the gtk3 dependency and add freetype2, dbus, and hicolor-icon-theme
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4dbd995e2f82..68cac1c04769 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Maintainer: Angelo Theodorou <encelo at gmail dot com>
pkgname=tracy
-pkgver=0.9
+pkgver=0.9.1
pkgrel=1
pkgdesc="Real-time, nanosecond resolution frame profiler"
arch=('i686' 'x86_64')
url="https://github.com/wolfpld/tracy"
license=('BSD')
-depends=('glfw-x11' 'gtk3' 'intel-tbb' 'capstone')
+depends=('glfw-x11' 'freetype2' 'dbus' 'hicolor-icon-theme' 'intel-tbb' 'capstone')
makedepends=('pkgconf' 'git')
optdepends=('xdg-desktop-portal: file dialogs')
provides=('tracy')
@@ -22,7 +22,7 @@ build() {
make -C csvexport/build/unix release
make -C import-chrome/build/unix release
make -C library/unix release
- make -C profiler/build/unix release
+ make -C profiler/build/unix release LEGACY=1
make -C update/build/unix release
}