summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAngelo Theodorou2022-04-17 20:26:56 +0200
committerAngelo Theodorou2022-04-17 20:26:56 +0200
commitb10fc554c6d524bfae55a087a72be8a88f46cb22 (patch)
treedff596e20f1d0e4d57fd56e71b0e9fde19de4550 /PKGBUILD
parent8171fbc1dfa0c26483a150f234a6c8b3c57a08ad (diff)
downloadaur-b10fc554c6d524bfae55a087a72be8a88f46cb22.tar.gz
Install trace file MIME type and icon from GitHub
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 965001c53402..61bf86e50272 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=tracy
pkgver=0.8
-pkgrel=2
+pkgrel=3
pkgdesc="Real-time, nanosecond resolution frame profiler"
arch=('i686' 'x86_64')
url="https://github.com/wolfpld/tracy"
@@ -12,8 +12,12 @@ depends=('glfw-x11' 'gtk3' 'intel-tbb' 'capstone')
makedepends=('pkgconf' 'git')
provides=('tracy')
conflicts=('tracy')
-source=("git+$url#tag=v$pkgver" "tracy.desktop")
-sha256sums=('SKIP' 'd3e0e3433e10a154ed38103a98600585a20ac49212f53370b2ead89971f47652')
+source=("git+$url#tag=v$pkgver" "tracy.desktop" "application-tracy.xml" "application-tracy.svg")
+sha256sums=('SKIP'
+ 'd3e0e3433e10a154ed38103a98600585a20ac49212f53370b2ead89971f47652'
+ 'f814d8f15a25b0014ca5781ae2b8941326c9f1e777d61368ec4c5128f3ddefcb'
+ '2f65177164c7601aef7b204d12c9e8dd94930056472d8f22d14339072cc6c8fb')
+
build() {
cd tracy
@@ -24,6 +28,8 @@ build() {
package() {
install -Dm644 tracy.desktop $pkgdir/usr/share/applications/tracy.desktop
+ install -Dm644 application-tracy.xml $pkgdir//usr/share/mime/packages/application-tracy.xml
+ install -Dm644 application-tracy.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/application-tracy.svg
cd tracy
install -Dm755 profiler/build/unix/Tracy-release $pkgdir/usr/bin/tracy