summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMilan Opath2018-05-03 14:22:22 +0200
committerMilan Opath2018-05-03 14:22:22 +0200
commitb7f0568b008f81c21a02de6a24df2cd45055a4ba (patch)
treef3dbacdaa197098f740f75955c24000f76977a11 /PKGBUILD
downloadaur-b7f0568b008f81c21a02de6a24df2cd45055a4ba.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6438cbdcd51f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Milan Opath <milan dot opath at gmail dot com>
+pkgname=traildb-git
+pkgver=0.6.r7.g3fb679f
+pkgrel=1
+arch=('x86_64')
+pkgdesc='An efficient tool for storing and querying series of events'
+depends=('judy' 'libarchive' 'pkg-config')
+makedepends=('git')
+provides=('tdb')
+license=('MIT')
+url='http://traildb.io'
+source=("traildb::git+https://github.com/traildb/traildb.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd traildb
+ GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git log -1 --format='%h')"
+}
+
+build() {
+ cd traildb
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd traildb
+ make DESTDIR="$pkgdir" install
+}