summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMubashshir2020-06-07 15:05:37 +0600
committerMubashshir2020-06-07 15:06:12 +0600
commit93d2eb244e793602045110bbe0028b6c24f7c475 (patch)
treef6b5dcb1aaee23a006333ca28105982cc9cafe66 /PKGBUILD
parentbaab897c972c85bcb086d2a06db510db296e838f (diff)
downloadaur-93d2eb244e793602045110bbe0028b6c24f7c475.tar.gz
Updated to 1.0.0b6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95d5c817a4ec..2dd446411db4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
# Maintainer: Mubashshir <ahmubashshir@gmail.com>
pkgname=trakt-scrobbler
-pkgver=1.0.0b4
-pkgrel=3
+pkgver=1.0.0b6
+pkgrel=0
pkgdesc="Automatically scrobble TV show episodes and movies you are watching to Trakt.tv! It keeps a history of everything you've watched!"
arch=(any)
url=https://github.com/iamkroot/trakt-scrobbler
license=(GPL2)
-depends=(
- $(curl -s https://pypi.org/pypi/trakt-scrobbler/$pkgver/json|jq -r '.info|.requires_python, .requires_dist[]'|grep -v win32|sed -E 's/^>=([[:digit:].-]+),<([[:digit:].-]+)$/python>=\1\npython<\2/;s/^([[:alnum:]]+) \(>=([[:alnum:].-]+),<([[:alnum:].-]+)\)$/python-\1>=\2\npython-\1<\3/')
- 'systemd'
-)
-optdepends=('libnotify: Provides Desktop Notifications.')
makedepends=(python-setuptools jq curl grep sed go-md2man gzip)
+depends=('systemd' $(curl -s https://pypi.org/pypi/trakt-scrobbler/$pkgver/json|jq -r '.info|.requires_python, .requires_dist[]'|grep -v '; '|sed -E 's/^>=([[:digit:].-]+),<([[:digit:].-]+)$/python>=\1\npython<\2/;s/^([[:alnum:]]+) \(>=([[:alnum:].-]+),<([[:alnum:].-]+)\)$/python-\1>=\2\npython-\1<\3/') )
+optdepends=('libnotify: Provides Desktop Notifications.')
source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz
trakts-man.md)
-sha256sums=(
- 1c450bf8b6f183a7ddf8bad1540e32969cce8518bf84b9fe16a2456f260ef116
- 81c3fb93bf01c0e6c0bbc9b2ef853da3f691bc3c50b4a87a68072b11ba72691c
-)
+sha256sums=('ba25e35d282b86e2d45414d9716e26d8dd511fe29f16b8e382cb8604ed7cad0c'
+ '81c3fb93bf01c0e6c0bbc9b2ef853da3f691bc3c50b4a87a68072b11ba72691c')
build() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py build
- go-md2man -in "$srcdir/trakts-man.md"|gzip -n > trakts.1.gz
+ go-md2man -in "$srcdir/trakts-man.md" 2>/dev/null|gzip -n > trakts.1.gz
}
package()
{