summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMubashshir2022-10-12 11:49:20 +0600
committerMubashshir2022-10-12 11:49:20 +0600
commitd6dd7c94e2986ae041403fe7d194ff20f3069205 (patch)
tree7a52cdfc41e880623cbc430a10165656892a3148 /PKGBUILD
parent78b9e8b16807d83e93e24709f35fa6fc685650b5 (diff)
downloadaur-d6dd7c94e2986ae041403fe7d194ff20f3069205.tar.gz
trakt-scrobbler-git: Fix broken cleo dependency
Signed-off-by: Mubashshir <ahmubashshir@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8045b1d4bda2..f8e5955e7349 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=trakt-scrobbler-git
pkgver=1.5.0.r2.gabf827e
-pkgrel=1
+pkgrel=2
pkgdesc="Automatically scrobble TV show episodes and movies you are watching to Trakt.tv! It keeps a history of everything you've watched!"
arch=(any)
@@ -14,7 +14,7 @@ depends=(
"systemd"
'python-appdirs<2.0.0' #auto-deps
'python-appdirs>=1.4.4' #auto-deps
- 'python-cleo<1.0.0' #auto-deps
+ 'python-cleo<=0.9' #auto-deps
'python-cleo>=0.8.1' #auto-deps
'python-confuse<3.0.0' #auto-deps
'python-confuse>=2.0.0' #auto-deps
@@ -60,6 +60,14 @@ pkgver() {
)
}
+prepare() {
+ cd "$srcdir/${pkgname%*-git}"
+
+ sed -i 's/cleo\s/cleo_v0 /' \
+ trakt_scrobbler/console.py \
+ trakt_scrobbler/commands/command.py \
+ pyproject.toml
+}
build() {
cd "$srcdir/${pkgname%*-git}"
python -m build --no-isolation --wheel