summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlpixTM2017-05-20 17:39:47 +0200
committerAlpixTM2017-05-20 17:39:47 +0200
commitc6337461accbb0ccf42e87b81ae0b3b5835382ed (patch)
treed8ac150db2742ccdb25f915bddb6e0114c99618c /PKGBUILD
downloadaur-c6337461accbb0ccf42e87b81ae0b3b5835382ed.tar.gz
initial, v0.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc9f9ab248c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+#Maintainer: AlpixTM aka Lukas N. <contact@alpix.eu>
+pkgname=transfersh
+pkgver=0.3
+pkgrel=1
+pkgdesc="unofficial command-line client for https://github.com/dutchcoders/transfer.sh (https://transfer.sh) Share a file easy with >transfersh filepath<"
+arch=('any')
+url="https://github.com/AlpixTM/transfersh"
+license=('AGPL')
+groups=()
+depends=('python' 'python-requests')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://github.com/AlpixTM/transfersh/archive/v$pkgver.tar.gz)
+noextract=()
+md5sums=('SKIP') #autofill using updpkgsums
+
+package() {
+ cd "$pkgname-$pkgver"
+install -D -m 755 "${srcdir}/transfersh-0.3/transfersh" "${pkgdir}/usr/bin/transfersh"
+install -D -m 755 "${srcdir}/transfersh-0.3/README.md" "${pkgdir}/usr/share/$pkgname/README.md"
+install -D -m 644 "${srcdir}/transfersh-0.3/LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}