summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorendlesseden2022-07-09 02:15:28 +1000
committerendlesseden2022-07-09 02:15:28 +1000
commit56b032ef7105893d5de68325198ab99c304dea8b (patch)
tree5e09bc6ebf190964053a0fb9d3e319146d191a04 /PKGBUILD
parent847b6be4d0ef02fe33e4b997997a0982272d2781 (diff)
downloadaur-56b032ef7105893d5de68325198ab99c304dea8b.tar.gz
updated: sources and depends.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 47 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf3d585722c3..86ecbfaa708e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,40 @@
_pkgbase=transmission
_pkgname=transmission-cli
pkgname=transmission-cli-git
-pkgver=3.00.r184.g59efe4642
+pkgver=3.00.r1187.g745adf833
pkgrel=1
arch=(x86_64)
url="http://www.transmissionbt.com/"
license=(MIT)
pkgdesc='Fast, easy, and free BitTorrent client (CLI tools, daemon and web client)'
-depends=(curl libevent libsystemd miniupnpc opendht libb64 libutp libnatpmp)
-makedepends=(cmake git)
+depends=(curl libevent libsystemd miniupnpc dht libb64 libnatpmp libdeflate libpsl fmt fast_float libutp)
+makedepends=(cmake publicsuffix-list git)
conflicts=(transmission-cli)
replaces=(transmission-cli)
provides=(transmission-cli)
-source=(git+https://github.com/transmission/transmission.git
+source=(transmission::git+https://github.com/transmission/transmission.git
transmission-cli.sysusers
- transmission-cli.tmpfiles)
+ transmission-cli.tmpfiles
+ "arc4"::"git+https://github.com/transmission/arc4"
+ "googletest"::"git+https://github.com/google/googletest.git"
+ "utfcpp"::"git+https://github.com/transmission/utfcpp#branch=post-3.2.1-transmission"
+ "libutp"::"git+https://github.com/transmission/libutp#branch=post-3.4-transmission")
+ #"$_pkgbase/third-party/libnatpmp"::"git+https://github.com/transmission/libnatpmp#branch=post-20151025-transmission"
+ #"$_pkgbase/third-party/miniupnpc"::"git+https://github.com/transmission/miniupnpc#branch=post-2.0.20170509-transmission"
+ #"$_pkgbase/third-party/libdeflate"::"git+https://github.com/transmission/libdeflate#branch=v1.11-plus-cmake"
+ #"$_pkgbase/third-party/libpsl"::"git+https://github.com/transmission/libpsl.git#branch=post-3.0.0-transmission"
+ #"$_pkgbase/third-party/fmt"::"git+https://github.com/transmission/fmt.git"
+ #"$_pkgbase/third-party/fast_float"::"git+https://github.com/transmission/fast_float"
+ #"$_pkgbase/third-party/dht"::"git+https://github.com/transmission/dht#branch=post-0.27-transmission"
+ #"$_pkgbase/third-party/libb64"::"git+https://github.com/transmission/libb64#branch=post-1.2.1-transmission"
+ #"$_pkgbase/third-party/libevent"::"git+https://github.com/transmission/libevent#branch=post-2.0.22-transmission"
sha256sums=('SKIP'
'641310fb0590d40e00bea1b5b9c843953ab78edf019109f276be9c6a7bdaf5b2'
- '1266032bb07e47d6bcdc7dabd74df2557cc466c33bf983a5881316a4cc098451')
+ '1266032bb07e47d6bcdc7dabd74df2557cc466c33bf983a5881316a4cc098451'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd $_pkgbase
@@ -29,8 +46,28 @@ pkgver() {
}
prepare() {
- cd $_pkgbase
- git submodule update --init
+ cd $_pkgbase/third-party
+ if [ -e arc4 ]; then
+ rm -r arc4
+ fi
+ ln -s $srcdir/arc4 arc4
+
+ if [ -e googletest ]; then
+ rm -r googletest
+ fi
+ ln -s $srcdir/googletest googletest
+
+ if [ -e utfcpp ]; then
+ rm -r utfcpp
+ fi
+ ln -s $srcdir/utfcpp utfcpp
+
+ if [ -e libutp ]; then
+ rm -r libutp
+ fi
+ ln -s $srcdir/libutp libutp
+
+# git submodule update --init
}
build() {
@@ -47,10 +84,10 @@ build() {
-DENABLE_QT=OFF \
-DENABLE_WEB=OFF \
-DINSTALL_LIB=ON \
+ -DUSE_SYSTEM_UTP=OFF \
-DUSE_SYSTEM_DHT=ON \
-DUSE_SYSTEM_B64=ON \
- -DUSE_SYSTEM_NATPMP=ON \
- -DUSE_SYSTEM_UTP=ON
+ -DUSE_SYSTEM_NATPMP=ON
make
}