summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrien Sohier2015-06-08 15:29:50 +0200
committerAdrien Sohier2015-06-08 15:29:50 +0200
commit90ebc1a88410fe3534f18fca0614564d12327514 (patch)
tree0f70542d1c40e6fb15e8cdc4aba9cbdf7ac6630a /PKGBUILD
downloadaur-90ebc1a88410fe3534f18fca0614564d12327514.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed62d5d45a6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Adrien Sohier <adrien.sohier@art-software.fr>
+
+pkgname=trash-py
+pkgver=1.0
+pkgrel=1
+pkgdesc='A cli trash in python 3'
+arch=('any')
+url="http://www.art-software.fr"
+license=('GPL')
+depends=('coreutils' 'gettext' 'python>=3.4')
+source=("Trash.py"
+ "en.po"
+ "fr.po")
+
+md5sums=('4ad5337338eeff9f0e0429c151faaad6'
+ 'ded9fa8a6f295d34b11e852c1cd48062'
+ 'b1b74c67e04ea5ca142075e8256f562f')
+
+build() {
+ cd "$srcdir"
+ msgfmt en.po -o en.mo
+ msgfmt fr.po -o fr.mo
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm644 en.mo "$pkgdir/usr/share/locale/en/LC_MESSAGES/trash.mo"
+ install -Dm644 fr.mo "$pkgdir/usr/share/locale/fr/LC_MESSAGES/trash.mo"
+ install -Dm755 Trash.py "$pkgdir/usr/bin/trash"
+}