summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhisbaan2023-10-23 15:22:12 -0400
committerhisbaan2023-10-23 15:22:12 -0400
commitaef1ee962cfef0d2b641824abdd195bb28f581d7 (patch)
tree32f1312c768857c156541446cc2e7fab2174d163 /PKGBUILD
parentc32462193fb6c9f3ad1c653609177b584e3b3e72 (diff)
downloadaur-aef1ee962cfef0d2b641824abdd195bb28f581d7.tar.gz
Fix src info (deps, provides, conflicts)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e864241d1ae8..c995cccc482c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,14 @@ pkgdesc='a cli system trash manager, alternative to rm and trash-cli'
arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/oberblastmeister/trashy"
license=('MIT' 'Apache')
-conflicts=('trash-cli')
depends_x86_64=('gcc-libs')
-makedepends=('cargo')
+makedepends=('git' 'cargo' 'binutils')
+provides=("${pkgname%-git}")
+conflicts=('trash-cli' "${pkgname%-git}")
source=('git+https://github.com/oberblastmeister/trashy.git')
sha256sums=('SKIP')
+
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "%s" "$(git describe --long | sed 's/v//;s/\([^-]*-\)g/r\1/;s/-/./g')"