summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDouglas McFadzean2015-06-08 12:19:58 +0100
committerDouglas McFadzean2015-06-08 12:19:58 +0100
commit7c71ce92a0952dedf3e192dc6cb70249623d0428 (patch)
tree93bd218a0ee6527f46d873dbdb66ef626da3d339 /PKGBUILD
downloadaur-7c71ce92a0952dedf3e192dc6cb70249623d0428.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bd3a85b9487
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: ninian <mcfadzean.org.uk ta linux>
+
+pkgname=treeline-unstable
+_pkg=${pkgname%%-*}
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Tree outliner and PIM which stores any kind of information within a tree structure; unstable development snapshot"
+arch=(any)
+url="http://treeline.bellz.org"
+license=('GPL')
+depends=('python-lxml' 'python-pyqt4' 'ispell')
+conflicts=('treeline')
+replaces=('treeline')
+install=treeline.install
+source=("http://sourceforge.net/projects/treeline/files/${pkgver}/treeline-${pkgver}.tar.gz/download")
+md5sums=('3f0a38b2c090dceacf89b7285cae99a6')
+
+package() {
+ cd "$srcdir/TreeLine"
+ python install.py -p /usr -b "$pkgdir"
+ cd ../..
+ install -Dm644 $_pkg.desktop "$pkgdir/usr/share/applications/$_pkg.desktop"
+ install -Dm644 $_pkg.xml "$pkgdir/usr/share/mime/packages/x-$_pkg.xml"
+}