summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSanskritFritz2022-05-06 11:55:08 +0200
committerSanskritFritz2022-05-06 11:55:08 +0200
commit04b9a2e20460d0d7951bfa2945632403b7c03bb1 (patch)
tree6c6086a5ee84fba9df3217d12ac0b06513ad0b4c /PKGBUILD
parent306b696e7432c3ebc27fbce6977d7799d40b307a (diff)
downloadaur-04b9a2e20460d0d7951bfa2945632403b7c03bb1.tar.gz
Fix directory name clash by building in _build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e527b5ae9aa..b84b6452f2cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
+# Maintainer: SanskritFritz (gmail)
_pkgname=treesheets
pkgname=$_pkgname-git
-pkgver=r297.7c4ad33
+pkgver=r341.ae6506a
pkgrel=1
pkgdesc='The ultimate replacement for spreadsheets, mind mappers, outliners, PIMs, text editors and small databases'
url='http://treesheets.com'
@@ -12,7 +13,7 @@ makedepends=('cmake' 'git')
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
source=(
- "git://github.com/aardappel/$_pkgname.git"
+ "git+https://github.com/aardappel/$_pkgname.git"
'myframe.patch'
)
@@ -34,19 +35,20 @@ prepare() {
build() {
cd $_pkgname
- cmake -DCMAKE_BUILD_TYPE=Release
+ cmake -S . -B _build -DCMAKE_BUILD_TYPE=Release
+ cd _build
make
}
package() {
cd $_pkgname
install -Dm644 ZLIB_LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -dm755 "$pkgdir/usr/share/applications"
+ install -Dm755 _build/$_pkgname "$pkgdir/usr/bin/$_pkgname"
cd TS
- install -dm755 "$pkgdir/usr/share/applications"
sed 's|Icon=images/|Icon=|' $_pkgname.desktop > "$pkgdir/usr/share/applications/$_pkgname.desktop"
install -Dm644 images/$_pkgname.svg "$pkgdir/usr/share/pixmaps/$_pkgname.svg"
- install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
install -dm755 "$pkgdir/usr/share/$_pkgname"
cp -R scripts "$pkgdir/usr/share/$_pkgname/scripts"