summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin MacMartin2016-01-08 17:18:21 -0500
committerKevin MacMartin2016-01-08 17:18:21 -0500
commitbdf347ea06ed37ac6fa36e0a0275afecd7c4cd75 (patch)
tree58d8ff66cef1db9da6f8195876b831bf47b9dea0 /PKGBUILD
parentc7be2d61669c8db8afbd6c509cf87892758bf9a8 (diff)
downloadaur-bdf347ea06ed37ac6fa36e0a0275afecd7c4cd75.tar.gz
Update to r126.a79eabe, use the .desktop file in the repo, install the icon to where the .desktop file expects it, no longer fix permissions in TS/examples as this was fixed upstream, and update the myframe patch to reflect changes to myframe.h
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7d0ef1e51bf..6ad06f40e232 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=treesheets
pkgname=$_pkgname-git
-pkgver=r122.2ce41d5
+pkgver=r126.a79eabe
pkgrel=1
pkgdesc='The ultimate replacement for spreadsheets, mind mappers, outliners, PIMs, text editors and small databases'
url='http://treesheets.com/'
@@ -10,13 +10,14 @@ license=('zlib')
depends=('wxgtk' 'webkitgtk2')
makedepends=('git')
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
-
-source=("git://github.com/aardappel/$_pkgname.git#branch=master"
- "$_pkgname.desktop"
- "myframe.patch")
-sha512sums=('SKIP'
- 'e423f46c1ea08d7429a3ffe027911dba52ded81228c6110f695ff19d56090ed93a6081bbc98329aa509f9888b042f995bfa3ce87cbcb34db9aab352f929b5bc2'
- '50ea4008f10d0e0248b77295fe664ca341a6225f4d3edb040d3bd0bba90943bcfe5372224cc92ea4047f1e7c4515ab32508752ba32c183faa195bcb239240e4b')
+source=(
+ "git://github.com/aardappel/$_pkgname.git#branch=master"
+ 'myframe.patch'
+)
+sha512sums=(
+ 'SKIP'
+ '7ea8b6947c334adebba774bcdd4db27670206a216de0c023c2b69aa3ad3b621165733a36f03f2e23bab1e7721982a24c29c4446754ba79c11c5735961ad04816'
+)
pkgver() {
cd $_pkgname
@@ -26,7 +27,6 @@ pkgver() {
prepare() {
cd $_pkgname
patch -p1 < ../myframe.patch
- find TS/examples -type f -exec chmod 644 '{}' \;
find TS/images -type f ! -iname '*.png' -delete
}
@@ -36,13 +36,17 @@ build() {
}
package() {
- install -Dm644 $_pkgname.desktop "$pkgdir/usr/share/applications/$_pkgname.desktop"
cd $_pkgname
install -Dm644 ZLIB_LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm755 TS/$_pkgname "$pkgdir/usr/bin/$_pkgname"
+
+ cd TS
+ install -Dm644 $_pkgname.desktop "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -Dm644 images/icon32.png "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
+
install -dm755 "$pkgdir/usr/share/$_pkgname"
- cp -R TS/examples "$pkgdir/usr/share/$_pkgname/examples"
- cp -R TS/images "$pkgdir/usr/share/$_pkgname/images"
- cp -R TS/docs "$pkgdir/usr/share/$_pkgname/docs"
+ cp -R examples "$pkgdir/usr/share/$_pkgname/examples"
+ cp -R images "$pkgdir/usr/share/$_pkgname/images"
+ cp -R docs "$pkgdir/usr/share/$_pkgname/docs"
}