summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGraham Smith2017-01-06 16:29:36 -0800
committerGraham Smith2017-01-06 16:29:36 -0800
commit9da70a0f61c2afd06003b9cee733175ba38af058 (patch)
tree701767bdc05e0a1683db778dab7a5035f93b1172 /PKGBUILD
downloadaur-9da70a0f61c2afd06003b9cee733175ba38af058.tar.gz
Initial push
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..3f8cd33e7faf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Graham Smith <gps1539 at gmail dot com>
+
+pkgname=trespass
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A secure password keeper written in python using gpg to protect account/user and user/password key value stores"
+arch=('any')
+license=('GPL')
+url='https://github.com/gps1539/trespass'
+depends=('python' 'python-numpy' 'gpg2')
+makedepends=()
+source=("https://raw.githubusercontent.com/gps1539/trespass/master/trespass.py")
+md5sums=('4ee384218bbc873e6770dd315c7984e8')
+
+package()
+{
+ install -d "$pkgdir/usr/bin/"
+ install -m755 "trespass.py" "$pkgdir/usr/bin/"
+}