summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZion Nimchuk2021-03-29 18:58:00 -0700
committerZion Nimchuk2021-03-29 18:58:00 -0700
commit96f3fa488b884f801e3ec23c7e8022db0834e36b (patch)
tree3db169dd2ebc692d9883149fe48bfe6df494d553 /PKGBUILD
parente81ba0b6fc91c94908b1718edee805af60d3f06a (diff)
downloadaur-96f3fa488b884f801e3ec23c7e8022db0834e36b.tar.gz
Version bump and switch to official GitHub binary
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 559189a5fe49..ca252d6f37bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=trex-bin
provides=('trex')
conflicts=('trex')
_cudaver=11.1
-pkgver=0.19.12
+pkgver=0.19.14
pkgrel=1
pkgdesc="T-Rex is a versatile cryptocurrency mining software for NVIDIA hardware. It supports a variety of algorithms and is trying to do its best to make it as fast and as convenient to use as possible."
arch=('x86_64')
@@ -11,13 +11,10 @@ license=('custom')
url="https://github.com/trexminer/T-Rex"
options=('!strip')
depends=('nvidia-utils')
-# For some reason the official GitHub Release doesn't work on Arch-based distros, so I'm using the file avialable from the dev here:
-# https://github.com/trexminer/T-Rex/issues/296#issuecomment-803103502
-source=("t-rex_${pkgver}_${_cudaver}.tar.gz"::"https://www.dropbox.com/s/yiy5gq26ownzp01/t-rex-${pkgver}-new-linux-cuda${_cudaver}.tar.gz?dl=1")
-sha512sums=('5d47725de7deb60405727287ee078c27a65cb2fd11790e6f432ed4dbc586f1b01bebbafb3811409bc9d3698aa84a34de9c7358bfe9dd6af57f84cd97e676f5ec')
+source=("t-rex_${pkgver}_${_cudaver}.tar.gz"::"https://github.com/trexminer/T-Rex/releases/download/0.19.14/t-rex-${pkgver}-linux-cuda${_cudaver}.tar.gz")
+sha512sums=('3b310637bc3799feaf42210e0133dde3f82398d614ce272a065b7f2784ca0ea7f83e35b422399079b43f3631e4cda981eaa2f15d934df3e7837e9c662571d75d')
package() {
cd "${srcdir}"
- ls
install -Dm755 "${srcdir}/t-rex" "${pkgdir}/usr/bin/t-rex"
}