summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2015-11-25 22:28:31 +0100
committerMichel Zou2015-11-25 22:28:31 +0100
commit0d44e3a9eaa7e77ec350d3a769a9ca8443e9609f (patch)
treeab22c5bb5e7dfdeaf760e3eabd2dc2e347edcd49 /PKGBUILD
downloadaur-0d44e3a9eaa7e77ec350d3a769a9ca8443e9609f.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efbdd33c6d31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+
+pkgname=tribler
+pkgver=6.5.0rc6
+_pkgver=6.5.0-rc6
+pkgrel=1
+pkgdesc="Privacy with BitTorrent and resilient to shut down"
+url="http://www.tribler.org/"
+arch=(any)
+license=('LGPL')
+depends=('python-cryptography' 'python-feedparser' 'python-gmpy2' 'python-apsw' 'python-cherrypy'
+'python-decorator' 'python-netifaces' 'python-requests' 'python-twisted' 'wxpython2.8' 'libsodium' 'libtorrent-rasterbar')
+optdepends=('python-vlc-git: for internal video player')
+makedepends=()
+source=("https://github.com/Tribler/tribler/releases/download/v${_pkgver}/Tribler-v${_pkgver}.tar.xz")
+md5sums=('3f57a3581a80af9d0b95d582aab472b5')
+
+package() {
+ cd "${srcdir}/tribler"
+ install -d "${pkgdir}"/usr/{bin,share/tribler}
+ install -m755 debian/bin/tribler "${pkgdir}"/usr/bin
+ cp -r Tribler "${pkgdir}"/usr/share/tribler
+}
+